Menu

Порт aux – что это такое и как пользоваться

подключение к console через aux, reverse telnet

На маршрутизаторах Cisco существует возможность подключиться к консольному порту (CONSOLE) через AUX порт другого маршрутизатора используя для этого обратное телнет (reverse telnet) соединение. 

Применяется это для абсолютно разных целей — резервированя доступа в случае падения основных интерфейсов, для удаленной настройки и т.п. 

У нас в распоряжение есть два маршрутизатора Cisco-R1 и Cisco-R2. Cisco-R1 доступен по сети, а Cisco-R2 маршрутизатор, который нам необходимо настроить используя reverse telnet. Первым делом нужно соеденить порт AUX на Cisco-R1 с портом CONSOLE на Cisco-R2 перевернутым (rollover) пачкордом как представлено на рисунке ниже.  

 

 

Схема соединения Cisco-R1 и Cisco-R2.

Обычно roll over пачкорд идет в поставке с оборудованием, если его нет, вы можете сделать его сами используя для этого обычную витую пару. Ниже представлена схема обжимки концов.

 

Цветовая схема обжимки концов для Rollew Over Cable.

Обратным telnet-соединением (reverse telnet) называется telnet-соединение с определенным портом маршрутизатора, при котором входящие telnet-соединения, переадресовывается наружу через выбранную асинхронную линию.

Настройка reverse telnet на Cisco

Ниже приведена простейшая конфигурация маршрутизатора Cisco-R1.

hostname Cisco-R1
!
aaa new-model
aaa authentication login default local
enable password 7 11081D081E1C
!
username admin privilege 15 password 7 06070B2C4540
!
interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.0
 no ip directed-broadcast
!
ip default-gateway 172.16.1.1
ip alias 172.16.1.3 2065
no ip http server
!
!
line con 0
 transport input none
line aux 0
 transport input telnet
line vty 0 4
 privilege level 15
 transport input telnet
!
no scheduler allocate
end

Для подключения необходимо определиться с номером линии для aux порта. Используем команду show line.

Cisco-R1#show line 
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
     0 CTY              -    -      -    -    -      0       0     0/0       -
    65 AUX   9600/9600  -    -      -    -    -     11       8     0/0       -
*   66 VTY              -    -      -    -    -    647       0     0/0       -
    67 VTY              -    -      -    -    -     77       0     0/0       -
    68 VTY              -    -      -    -    -      3       0     0/0       -
    69 VTY              -    -      -    -    -      0       0     0/0       -
    70 VTY              -    -      -    -    -      0       0     0/0       -
Line(s) not in async mode -or- with no hardware support: 
1-64

Из вывода команды видно что номер линии для AUX равен 65.

Тепер чтобы подключиться к маршрутизатору Cisco-R2 через порт aux на Cisco-R1 воспользуемся обратным телнет соединением.

telnet 172.16.1.2 2065

Для доступа потребуется ввести логин и пароль маршрутизатора Cisco-R1. IP-адрес 172.16.1.2 принадлежит интерфейсу FastEthernet 0/0 маршрутизатора Cisco-R1, а 2065 — номер порта который вычисляется как 2000 + [номер_линии]. Получается: 2000+65=2065.

Можно себе упростить чуток жизнь прописав alias

ip alias 172.16.1.3 2065

Эта команда ассоциирует ip-адрес с портом для обратного telnet-соединения. Теперь подключиться через консольный порт маршрутизатора можно просто набирая telnet 172.16.1.3

Для прерывания обратного telnet соединения если вы заходите с Cisco-R1 используем:

ctrl+6 затем x
Cisco-R1# disconnect
Closing connection to 172.16.1.3 [confirm]

Команда disconnect закрывает соединение через aux порт.

Если aux линия уже занята и вы неможете подключиться просто убейте соединения на этой линии с помощю команды:

clear line aux 0

Обратите внимание часто причиной неудачного соединения может быть отсуствие настроек разрешающих telnet соединение для линии aux 0.

line aux 0
 transport input telnet

Вот и все. Рассмотрение reverse telnet на оборудование cisco завершено.

admin-gu.ru

Cisco AUX to console — как разновидность удаленного управления / Песочница / Хабр

Бывает ряд ситуаций когда надо удаленно настроить новое сетевое оборудование(cisco, Juniper и т.д. где консоль имеет распайку cisco console RJ-45) через консоль, не имея возможности подключиться к удаленному компьютеру. Есть только доступ telnet/ssh к маршрутизатору cisco(R1) на удаленной площадке где AUX RJ-45(варианты: 2811, 3845, 3660 и т.д.). И этого более чем достаточно.
К примеру, вы сетевой администратор, находитесь постоянно в головном офисе, пришло новое оборудование на замену старого, в branch офис, который находиться за 3-9 земель от вас. Безусловно в каждом офисе есть квалифицированные сотрудники ИТ-отдела, но у них нет сертификата CCIE. Но несмотря на это они знают что такое кримпер и умеют им пользоваться.

Необходимые действия:
  • Настроить AUX cisco(R1)
  • Соединить AUX cisco(R1) с консолью нового оборудования(Rn).
  • Посмотреть на R1, какая линия AUX
  • Терминал подключение.
Настройка R1

Нам надо настроить AUX, заходим на R1 в режим конфигурации, в настойку AUX и выставляем параметры скорости (по умолчанию 9600), число бит на сигнал (по умолчанию 8), четность (по умолчанию NONE, стопбит (по умолчанию 1), отключаем активизацию по символам, устанавливаем none на символ разорвать соединения и отключаем редактирование. Не забываем про любимый telnet.
telnet R1
Trying 10.2.2.2…
Connected to r1.
Escape character is ‘^]’.

conf t
 line aux 0
  speed 9600
  databits 8
  parity none
  stopbits 1
  exec-timeout 0 0
  no activation-character
  no editing
  transport input telnet
  transport output none
  escape-character NONE


и не забываем сохранить
do wr
Кроссирование

Как мы знаем из курса CCNA. Распайка AUX, почти такая же как consоle. По этому нужен кабель RJ-45 – RJ-45 перевернутый(Cisco Console Rollover Cable):
№ провода в паре Console port № провода в паре Auxillary port
1 8 RTS Output
2 DTR Output 7 DTR Output
3 TXD Outputt 6 TXD Output
4 GND 5 GND
5 GND 4 GND
6 RXD Input 3 RXD Input
7 DSR Input 2 DSR Input
8 1 CTS Input

Обжимаем кабель — одним концом в R1 AUX, вторым в Rn CONSOLE
Осмотр

В привилегированном режиме смотрим номер линии:
sh line
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
*     0    0 CTY              -    -      -    -    -     0   2574    0/0      -
      1    1 AUX   9600/9600  -    -      -    -    -     0      0    0/0      -
    706  706 VTY              -    -      -    -    -     0      0    0/0      -
    707  707 VTY              -    -      -    -    -     0      0    0/0      -
    708  708 VTY              -    -      -    -    -     0      0    0/0      -
    709  709 VTY              -    -      -    -    -     0      0    0/0      -
    710  710 VTY              -    -      -    -    -     0      0    0/0      -
    711  711 VTY              -    -      -    -    -     0      0    0/0      -
    712  712 VTY              -    -      -    -    -     0      0    0/0      -
    713  713 VTY              -    -      -    -    -     0      0    0/0      -
    714  714 VTY              -    -      -    -    -     0      0    0/0      -
    715  715 VTY              -    -      -    -    -     0      0    0/0      -
    716  716 VTY              -    -      -    -    -     0      0    0/0      -
    717  717 VTY              -    -      -    -    -     0      0    0/0      -
    718  718 VTY              -    -      -    -    -     0      0    0/0      -
    719  719 VTY              -    -      -    -    -     0      0    0/0      -
    720  720 VTY              -    -      -    -    -     0      0    0/0      -
    721  721 VTY              -    -      -    -    -     0      0    0/0      -

Line(s) not in async mode -or- with no hardware support: 
2-705

* — указывает что используется.
Номер линии бывает разный:
sh line aux 0
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
      0 CTY              -    -      -    -    -      0       0     0/0       -
*   225 AUX   9600/9600  -    -      -    -    -      1       0     0/0       -
*   226 VTY              -    -      -    -    -    339       0     0/0       -
    227 VTY              -    -      -    -    -      1       0     0/0       -
    228 VTY              -    -      -    -    -      0       0     0/0       -
    229 VTY              -    -      -    -    -      0       0     0/0       -
    230 VTY              -    -      -    -    -      0       0     0/0       -

Line(s) not in async mode -or- with no hardware support: 
1-224


Работает

У нас всё отлажено, всё настроено, осталось подключиться.
Прибавляем 2000 к значению номера линии 1, получаем 2001, это номер порта.
telnet r1 2001
Trying 10.2.2.2…
Connected to R1.
Escape character is ‘^]’.

Would you like to enter the initial dialog? [yes]:


И добро пожаловать на оборудование.
P.S.: В следующей статье могу поделиться опытом использования консольных терминалов Avocent серии ACS


habr.com

Соединение маршрутизаторов Cisco через AUX (консольные) порты | cisco

В этом документе кратко рассмотрим пример связи двух маршрутизаторов Cisco напрямую, не используя модемов и другого телекоммуникационного оборудования (DCE) устройств (через консольные порты, обычно используемые только для управления маршрутизаторами). Материал для статьи взят с http://www.opennet.ru/base/cisco/cisco_aux_connect.txt.htm.

При необходимости информацию по настройке модема на вспомогательном (AUX) порту или на консольном порту, Вы сможете найти на сайте Cisco — Modem-Router Connection Guide или Access-Dial Technology Support .

В этой статье описывается соединение двух маршрутизаторов Cisco, напрямую через асинхронные AUX (вспомогательные порты) порты, при помощи нуль модемного кабеля (rollover cable) и PPP протокола. Порты AUX являются data terminal equipment (DTE) устройствами, а для соединения между собой двух DTE устройств нужен нуль модемный кабель (rollover cable). Терминальный (нуль-модемный) кабель (part number CAB-500RJ= ) как правило уже поставляется в комплекте с каждым Сisco маршрутизатором, для обеспечения консольного соединения по RJ-45. Если AUX порт одного из маршрутизаторов в связке является DB-25, используйте RJ-45-на-DB-25 адаптер, обозначенный как «терминальный», с нуль-модемным кабелем.

Примечание: Убедитесь что длина кабелей не превышает 50 футов (около 15 метров), согласно ограничениям EIA/TIA-232 (больше известном как RS-232).

За более подробной информацией о кабелях, обращайтесь к Cabling Guide for RJ-45 Console and AUX Ports.

Для связи между собой маршрутизаторов, которые имеют не RJ-45 а DB-25 AUX порты (например Cisco 4500, 7200 и 7500), Вам понадобится DB-25 на DB-25 нуль модемный кабель. Этот кабель Вы можете приобрести отдельно. Убедитесь что «распиновка» вашего DB-25 на DB-25 нуль модемного кабеля соответствует указанной в таблице 1.

Таблица 1 — «Распиновка» DB-25 на DB-25 нуль модемного кабеля.
           DB-25       DB-25
           RxD  2  —   3  TXD
           TxD  3  —   2  RxD
           CTS  4  —   5  RTS
           RTS  5  —   4  CTS
           DTR  6  —   20 CD
           DSR  8  —   20 CD
           CD  20  —   6  DTR
           CD  20  —   8  DSR
           GND  7  —   7  GND

Настройка
В этой части документа подробно рассмотрим настройку маршрутизаторов. Примечание: за более подробной информацией по использованным в данном примере командам, обращайтесь к Command Lookup Tool (для зарегистрированных пользователей).

Схема примера показана ниже:

Далее приведены конфигурации обоих маршрутизаторов участвующих в примере, Router 1 и Router 2.

Примечание: В этом примере мы настраиваем постоянное (выделенное) соединение между маршрутизаторами, с использованием IP адресов на AUX портах.

[Маршрутизатор 1]
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
interface Ethernet0
  no ip address
  shutdown
!
interface Serial0
  no ip address
  shutdown
!
interface Serial1
  no ip address
  shutdown
!
interface Async1
!— Асинхронный интерфейс относящийся к AUX порту.
!— Чтобы определить какой асинхронный интерфейс соответствует вашему AUX
!—порту используйте команду show line.
  ip address 192.168.10.1 255.255.255.0
  !— IP адреса на AUX портах обоих маршрутизаторов должны находиться в одной
  !— подсети.
  encapsulation ppp
  !— Включаем PPP.
  async dynamic routing
  !— Разрешаем маршрутизацию на интерфейсе.
  async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1
!— Устанавливаем статический маршрут на интерфейс Async1 (AUX порт).

logging buffered
!
line con 0
  exec-timeout 0 0
line aux 0
!— Настройки линии для AUX порта.
  modem InOut
  transport input all
  !— Разрешаем на линии все протоколы.
  rxspeed 38400
  !— Устанавливаем скорость приёма Rx (должна быть идентична скорости TX на
  !— другом маршрутизаторе).
  Txspeed 38400
  !— Устанавливаем скорость передачи Tx (должна быть идентична скорости RX на
  !— другом маршрутизаторе).
  flowcontrol hardware
line vty 0 4
  login
!
end

[Маршрутизатор  2]
 version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname Router2
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
interface Serial0
  no ip address
  shutdown
!
interface Serial1
  no ip address
  shutdown
!
interface Async1
!— Асинхронный интерфейс относящийся к AUX порту.
!— Чтобы определить какой асинхронный интерфейс соответствует вашему AUX
!—порту используйте команду show line.
  ip address 192.168.10.2 255.255.255.0

  !— IP адреса на AUX портах обоих маршрутизаторов должны находиться в одной
  !— подсети.
  encapsulation ppp
  !— Включаем PPP.
  async dynamic routing
  !— Разрешаем маршрутизацию на интерфейсе.
  async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
!— Здесь статический маршрут указываем на интерфейс Ethernet0.

logging buffered
!
line con 0
  exec-timeout 0 0
line aux 0
!— Настройки линии для AUX порта.
  modem InOut
  transport input all
  !— Разрешаем на линии все протоколы.
  rxspeed 38400
  !— Устанавливаем скорость приёма Rx (должна быть идентична скорости TX на
  !— другом маршрутизаторе).
  txspeed 38400
  !— Устанавливаем скорость передачи Tx (должна быть идентична скорости RX на

  !— другом маршрутизаторе).
  flowcontrol hardware

line vty 0 4
  login
!
end

Отладка и диагностика
В данной секции документа находится информация которая поможет вам провести диагностику и устранить возможные проблемы. Перед использованием команд debug, пожалуйста ознакомтесь с Important Information on Debug Commands.

Проводя диагностику следует выполнить несколько шагов:
1. При помоши команды show line определить асинхронный интерфейс который принадлежит AUX порту. В большинстве маршрутизаторов AUX порту принадлежит асинхронный интерфейс — interface async 1, а у Access серверов интерфейс AUX порта находится за всеми асинхронными линиями (tty line). Если например Ваш маршрутизатор имеет 16 асинхронных линий, то AUX порт будет 17, следовательно в этом случае параметры AUX порта следует настраивать на interface async 17.

В любом случае проверить какой из асинхронных интерфейсов на Вашем маршрутизаторе соответствует AUX порту можно командой show line. Вот пример вывода данной команды, в котором видно что AUX порту соответствует interface Async1:
Router1#show line
Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
*  0 CTY              —    —     —    —    —    0      0       0/0
A  1 AUX  38400/38400 — inout    —    —    —    0      0       0/0
   2 VTY              —    —     —    —    —    0      0       0/0
   3 VTY              —    —     —    —    —    0      0       0/0
   4 VTY              —    —     —    —    —    0      0       0/0
   5 VTY              —    —     —    —    —    0      0       0/0
   6 VTY              —    —     —    —    —    0      0       0/0

2. Ввести команду show line aux 0

3. Убедиться что все сигналы на AUX интерфейсе находятся в состоянии UP (например Clear To Send (CTS), Request To Send (RTS), data terminal ready (DTR), и Carrier Detect (CD)). Если все сделано правильно все эти сигналы должны быть в состоянии UP (подняты). Если какой то из них имеет состояние NO (например No-CTS), это означает что этот сигнал отсутствует, тоесть находится в состоянии Down. Если это так, следует внимательно проверить отсутствие ошибок в конфигурации маршрутизаторов с обоих сторон, убедится что Вы настроили правильные асинхронные интерфейсы для AUX портов.

Примечание: Если команда show line показывает что DSR сигнал отсутствует (noDSR), следует убедится что в DB25 на DB25 нуль модемном кабеле, контакты 6 и 8 соединены с контактом 20 на обоих концах кабеля. Как указано выше в таблице 1.

Router1#show line aux 0
 Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
A  1 AUX 38400/38400  — inout    —    —    —    0      0       0/0

Line 1, Location: «», Type: «»
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
Status: Ready, Active, Async Interface Active
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
  Modem Callout, Modem RI is CD, Line is permanent async interface
Modem state: Ready
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   —     —       none
Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
           00:10:00      never                       none   not set
Modem type is unknown.
Session limit is not set.
Time since activation: 00:00:30
Editing is enabled.
History is enabled, history size is 10.
Full user help is disabled
Allowed transports are pad v120 telnet.  Preferred is telnet.
No output characters are padded
No special data dispatching characters
Line is running PPP for address 192.168.10.2.
0 output packets queued, 1 input packets.
 Async Escape map is 00000000000000000101000000000000
Modem hardware state: CTS* DSR*  DTR RTS

3. Если конфигурация проверена и оказалась верной, а сигналы не появились, следует заменить (перепроверить) нуль модемный кабель между маршрутизаторами.

4. Используйте команды shutdown и no shutdown на асинхронном интерфейсе для разрыва соединения.

Команды для отладки
Используйте команды debug, чтобы убедится что линия поднялась и работает корректно.

debug ppp negotiation — выводит подробную информацию касательно протокола PPP, и процесса его работы Link Control Protocol (LCP), Authentication, и Network Control Protocol (NCP). Если CONFREQ был послан но CONFACK не получен, следует проверить все кабельные соединения и правильность настройки интерфейсов.

debug ppp authentication — показывает процесс PPP аутентификации (если таковая была настроена), также содержит информацию о работе CHAP и PAP. В нашем примере аутентификация не используется, поэтому данная команда не интересна.

debug ppp error  — выводит информацию о возможных ошибках протокола PPP.

Схожая информация
     * Modem-Router Connection Guide
     * Dialup Technology: Troubleshooting Techniques
     * Configuring Dialout using a Modem on the AUX Port
     * Technical Support — Cisco Systems
 

microsin.net

Методы доступа. Консоль. Telnet и SSH. AUX

Есть несколько способов получить доступ к среде CLI. Наиболее распространенные методы:

  • Консоль

  • Telnet или SSH

  • Порт AUX

Консоль

К CLI можно получить доступ через консольный сеанс, также известный как строка CTY. Консоль использует низкоскоростное последовательное соединение, которое происходит через непосредственное подключение компьютера или терминала к консольному порту на маршрутизаторе или коммутаторе.

Консольный порт является портом управления, который обеспечивает внеполосный доступ к маршрутизатору. Консольный порт доступен, даже если никакие сетевые службы не были сконфигурированы на устройстве. Консольный порт часто используется, чтобы получить доступ к устройству, когда сетевые службы не были запущены или перестали работать.

Примеры использования консоли:

  • Начальная конфигурация сетевого устройства

  • Процедуры аварийного восстановления и поиск и устранение неисправностей, когда удаленный доступ не возможен

  • Процедуры восстановления пароля

Когда маршрутизатор впервые начинает использоваться, сетевые параметры еще не сконфигурированы. Поэтому, маршрутизатор не может осуществлять связь через сеть. Чтобы подготовить его к начальному запуску и конфигурации, на компьютере запускают программное обеспечение эмуляции терминала для соединения с консольным портом устройства. Команды конфигурации для настройки маршрутизатора могут быть введены через соединенный компьютер.

Во время работы, если к маршрутизатору нельзя получить доступ удаленно, соединение с консолью через компьютер может позволить определить состояние устройства. По умолчанию консоль выводит информацию о запуске устройства, об отладке и сообщения об ошибках.

Для многих устройств с IOS консольный доступ не требует никакой формы безопасности по умолчанию. Однако, консоль должна быть сконфигурирована с паролями, чтобы предотвратить несанкционированный доступ к устройству. Когда пароль теряется, существует специальный набор процедур для того, чтобы обойти пароль и получить доступ к устройству. Устройство должно быть расположено в заблокированной комнате или стойке для оборудования, чтобы предотвратить физический доступ.

Telnet и SSH

Telnet — метод для получения удаленного доступа к сеансу CLI маршрутизатора. В отличие от консольного соединения, сеансы Telnet требуют активных сетевых служб на устройстве. У сетевого устройства должен быть по крайней мере один активный интерфейс, сконфигурированный с адресом Уровня 3, таким как адрес IPv4. Устройства с Cisco IOS включают процесс сервера Telnet, который запускается при запуске устройства. IOS также содержит клиент Telnet.

Узел с клиентом Telnet может получить доступ к сеансам vty, работающим на устройстве Cisco. Из соображений безопасности IOS требует, чтобы сеанс Telnet использовал пароль в качестве минимальный метода аутентификации. Методы установки учетных записей и паролей будут обсуждаться в последующих статьях данной рубрики.

Протовол Безопасной Оболочки (SSH) является более безопасным методом для удаленного доступа к устройству. Этот протокол обеспечивает удаленный вход в систему, подобный Telnet, за исключением того, что он использует более безопасные сетевые службы.

SSH обеспечивает более сильную аутентификацию по паролю, чем Telnet, и использует шифрование, транспортируя данные сеанса. Сеанс SSH шифрует все передачи данных между клиентом и устройством IOS. Это защищает идентификатор пользователя, пароль и детали сеанса управления. Следуя передовой практике, всегда используйте SSH вместо Telnet, когда только это возможно.

Большинство более новых версий IOS содержат сервер SSH. В некоторых устройствах эта служба включена по умолчанию. Другие устройства требуют, чтобы сервер SSH был включен.

Устройства IOS также включают клиент SSH, который может использоваться, чтобы установить сеансы SSH с другими устройствами. Точно так же можно использовать удаленный компьютер с клиентом SSH, чтобы запустить безопасный сеанс CLI. Клиентское программное обеспечение SSH не поставляется по умолчанию на всех компьютерных операционных системах. Вы, возможно, должны будете получить, установить и сконфигурировать клиентское программное обеспечение SSH для Вашего компьютера.

AUX

Другой способ установить сеанс CLI удаленно — через телефонное коммутируемое соединение, используя модем, соединенный с портом маршрутизатора AUX. Подобно консольному соединению, этот метод не требует конфигурации каких-либо сетевых служб или их доступности на устройстве.

Порт AUX может также использоваться локально в качестве консольного порта при прямом подключении к компьютеру, выполняющему программу эмуляции терминала. Консольный порт требуется для конфигурации маршрутизатора, но не все маршрутизаторы имеют вспомогательный порт. Консольный порт также предпочитается вспомогательному порту для диагностики, потому что он отображает детали запуска маршрутизатора, информацию об отладке и сообщения об ошибках по умолчанию.

Обычно, единственный случай, когда порт AUX используется локально вместо консольного порта — когда есть проблемы с использованием консольного порта, например, если некоторые параметры консоли неизвестны.

Далее: Канальный уровень — Управление Передачей через Локальные Носители

Смотрите также

Написать

datanets.ru

USB AUX порт. — бортжурнал Volkswagen Passat 1991 года на DRIVE2

Полный размер

Изначально, в машине, стояла неплохая магнитола JVC, но в один прекрасный день, задний правый канал, вместо музыки, стал издавать гудение. Проблему решил просто, взял и поменял на магнитолу с 44-ой сотки, которая стояла у меня во дворе без документов. Clarion, стоявший в сотке, тоже был неплохим, но стареньким воспроизводившем, однако, очень приличный, по качеству, звук. И всё же, какой бы хорошей магнитола не была, время и технологии идут вперёд и компакт диски уходят в прошлое, а их место занимают флэшки. «Кларич» не имел возможности подключить флэшку поэтому, через какое то время, я приобрёл цифровой ресивер Пионер с usb aux входом, правда только через кабеля, подключаемые с тыльной стороны. Подключать флэшку, таким образом, не очень удобно, поэтому я решил найти стандартное место подключения. Этим местом стала заглушка кнопки на консоли? Взяв, уже не помню от чего, usb разъём с кабелем, просто соединил его со стандартным проводом, а сам разъём врезал в заглушку . Всё работало, как положено и вроде бы даже удобно, но передний пассажир постоянно задевал флэшку коленом, что нарушало контакт в разъёме. Необходимо было перенести разъём в более безопасное для него место.
Как то товарищ подогнал мне блок с aux usb разъёмами и 12ти вольтовой розеткой от КИА сид и я решил подключить его к ресиверу. Найдя в интернете распиновку контактов, подключил к стандартным кабелям ресивера. Всё подключилось и работало, как надо. Теперь нужно было найти подходящее место для блока. После непродолжительных поисков, решено было внедрить блок на место пепельницы, которая мне, как человеку некурящему, в общем то, не нужна, а для курящих пассажиров, в машине имеется переносная «пепелка» от того-же КИА сид. Не буду описывать процесс переделки стандартной пепельницы в место, если можно так выразиться, для блока, так как это, на мой взгляд, просто неинтересно. Остановлюсь, более подробно, на описании установке самого блока. Изначально я не нашёл подходящего разъёма к блоку, поэтому пришлось использовать компъютерные разъёмы, которые, в общем то, подошли, но подключать их пришлось адресно. Блок я разделил на, собственно, сам блок и розетку. Порывшись в своих необъятных запасах всевозможного барахла, нашёл рамку от такого же блока, но от предыдущего поколения КИА сид . Решил их скрестить, а вместо розетки внедрил прикуриватель, потому что в нём есть подсветка. Что и как получилось, думаю понятно из фотографий. Таким образом появилась первая версия USB порта, которая, честно говоря, не очень мне нравилась.
Через пару недель, я нашёл таки подходящий разъём, но на два пина больше. Лишние контакты я просто отрезал . Всё подошло. Соединил провода, а блок вернув в исходное состояние просто врезал в, предварительно обклееную карпетом, рамку . Получилось, по моему, немного аккуратнее.

Полученным результатом я в общем то доволен. Получилось всё весьма удобно, обозначения разъёмов подсвечиваются. Правда ночью не видно самого разъёма, поэтому думаю сделать какую нибудь фоновую подсветку, если переборю свою лень.

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

Полный размер

www.drive2.ru

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *